Bug #993

module md5 is deprecated

Added by planetmaker over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2010-06-05
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

From the CF:
/usr/lib/python2.6/site-packages/ply/yacc.py:74: DeprecationWarning: the md5 module is deprecated; use hashlib instead
import re, types, sys, cStringIO, md5, os.path

History

#1 Updated by yexo over 9 years ago

Caused by old version of ply. The warning is not displayed in 3.3, probably fixed in 3.0

#2 Updated by Alberth over 9 years ago

January 13, 2009 (r54) introduced CRC32 checking instead of MD5 in PLY. In that same revision, the version got updated to 3.0 .

May 23, 2009 (r72) replaced CRC32 checking again with MD5 checking again (crc checking was not good enough). In that same revision, the version got updated to 3.2.
It does import hashlib first though, which apparently is not found in the used python version (or that version has no md5 in hashlib).

Is there something that should be done in the code for this issue? (ie, why is it not closed already?)

#3 Updated by yexo over 9 years ago

  • Status changed from Confirmed to Closed

Nothing we can do about this

Also available in: Atom PDF