Bug #781

farm hedges not properly aligned

Added by planetmaker over 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:2010-03-07
Priority:LowDue date:
Assignee:-% Done:

100%

Category:Base
Target version:0.4.0

Description

The (brown) hedges seem to align a bit strangely on hill sides

ogfx_hedges.png (139 KB) planetmaker, 2010-03-07 12:40

landscape031.pcx (497 KB) andythenorth, 2010-03-20 13:26

zoom_hedges.png - comparison of old and new farm field fences (102 KB) planetmaker, 2010-03-20 16:52

fences.png - zoomed-in fences (970 KB) planetmaker, 2010-03-21 09:40

Associated revisions

Revision 380:24fff851f713
Added by planetmaker over 9 years ago

Fix [#781]: Improve visual continuation of adjacent fences around farm land (andythenorth)

Revision 380:24fff851f713
Added by planetmaker over 9 years ago

Fix [#781]: Improve visual continuation of adjacent fences around farm land (andythenorth)

Revision 706:39216dc49ba9
Added by foobar over 8 years ago

Fix #781: improve farm field fences and hedges

Revision 706:39216dc49ba9
Added by foobar over 8 years ago

Fix #781: improve farm field fences and hedges

History

#1 Updated by planetmaker over 9 years ago

  • Category set to Base

#2 Updated by Ammler over 9 years ago

  • Target version changed from 0.2.2 to 0.3.0

Someone able to tell which sprite # that is?

#3 Updated by andythenorth over 9 years ago

Looks like sprites 893 and 894 in landscape031.pcx to me.

I've attached a modified landscape031.pcx, this is a quick hack of those fence sprites and is untested in game.

#4 Updated by planetmaker over 9 years ago

#5 Updated by planetmaker over 9 years ago

  • File fences.png added
  • Status changed from Confirmed to Feedback
  • Priority changed from Normal to Low
  • Target version changed from 0.3.0 to 0.4.0
  • % Done changed from 0 to 70

The current fences as of r380 are a big improvement. Looking at the fences in very close detail it seems to me that the lower board is being swallowed by the earth in some cases. Is it worth to correct this and put more effort into it? E.g. see 'fences.png' where the mouse cursor is; it looks like the fence is getting lower the higher the mountain slopes. The same holds true for the perpendicular direction to the right in the image. Without zooming in like in the screenshot this is not really that much obvious, though.

#6 Updated by athanasios over 9 years ago

Well, I am not the artist, but IMO for now it is acceptable.

#7 Updated by Ammler over 9 years ago

The question is, why does it look fine with original fences, why not with opengfx?

#8 Updated by foobar over 8 years ago

Problem with these fences is that they follow a different slope than the terrain. Shifting some pixels up/down should fix it; shouldn't be too problematic.

#9 Updated by foobar over 8 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 70 to 100

Applied in changeset 39216dc49ba9.

Also available in: Atom PDF