Feature #7729

Maglev railbus

Added by Transportman almost 5 years ago. Updated about 4 years ago.

Status:ClosedStart date:2015-07-15
Priority:NormalDue date:
Assignee:Transportman% Done:

100%

Category:Code
Target version:2.0-alpha1

turbobus.PNG - Euro flag version (2.35 KB) EmperorJake, 2016-01-10 06:49

turbobus-2cc.PNG - 2cc flag version (2.37 KB) EmperorJake, 2016-01-10 06:49

Associated revisions

Revision 731:4d5b4606abe0
Added by Transportman over 4 years ago

Feature: Maglev railbus (closes #7729)

Revision 733:f542be4242da
Added by Transportman over 4 years ago

Fix #7964: Turbobus properties were wrong (also for issue #7729)

Revision 775:35833e95064b
Added by Transportman about 4 years ago

Fix #7729: Maglev railbus ID changed

History

#1 Updated by EmperorJake almost 5 years ago

  • File turbobus.PNG added

I tweaked and templated the sprites. It uses the 10/8 template. I'm not sure if you want to keep the flag or not, seeing as it's a fantasy vehicle.

#2 Updated by Transportman almost 5 years ago

10/8 is fine. I'm not sure about the flag, so maybe the flag can be replaced by something representing the world, or just no flag at all.

#4 Updated by Transportman over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Closed

Applied in changeset 2ccts|commit:4d5b4606abe0.

#5 Updated by EmperorJake over 4 years ago

  • File deleted (turbobus.PNG)

#6 Updated by EmperorJake over 4 years ago

Oh good, I see it's been added. There's a misalignment on the depot sprite, not due to the file because it's aligned the same as other 10/8 railbuses. Also the capacity seems to be twice what was given, but I'm not complaining.

edit: Also the Maglev MU wagon is attachable to it, that probably shouldn't be the case.

I've also discovered a small pixel artifact while testing it, here's a fixed version.

There's also a version with the 2cc flag that the wagons use in case you prefer that over the EU flag.

#7 Updated by Transportman over 4 years ago

  • Status changed from Closed to Reopened
  • Category set to Code

#8 Updated by Transportman over 4 years ago

I fixed most of the problems, but for some reason there is a problem with the articulated parts not working and I can't find why it is not working.

#9 Updated by Transportman about 4 years ago

  • Status changed from Reopened to Closed

Applied in changeset 2ccts|commit:35833e95064b.

Also available in: Atom PDF