Bug #77

town building misalignment

Added by foobar over 10 years ago. Updated over 9 years ago.

Status:ClosedStart date:2009-05-24
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Base
Target version:0.2.2

Description

Several town buildings are misaligned.

Untitled-1.png - As indicated by arrow (35.6 KB) foobar, 2009-06-27 15:47

misaligned_building_1.sav - savegame (0.7.1) (102 KB) foobar, 2009-06-27 15:47

largeofficeblockconstructionstage.png (6.11 KB) foobar, 2009-08-14 16:38

ogfx_snow_house.png (25.6 KB) Ammler, 2009-12-22 16:56

ogfx_snow_house1.png (14.3 KB) Ammler, 2009-12-22 17:16

houses_1461.png (68.9 KB) Ammler, 2010-03-12 23:16

houses_1470.png (47.5 KB) Ammler, 2010-03-12 23:16

houses_1519.png (42.7 KB) Ammler, 2010-03-12 23:16

opengfx_building_test_1.sav (18 KB) Ammler, 2010-03-12 23:18

Associated revisions

Revision 169:ca821b55349e
Added by foobar over 10 years ago

Fix (issue #77): Building misalignment

Revision 169:ca821b55349e
Added by foobar over 10 years ago

Fix (issue #77): Building misalignment

Revision 186:f2962f5f0fdd
Added by planetmaker over 10 years ago

Fix: Alignment of construction phase of temperate office building (part of issue #77)

Revision 186:f2962f5f0fdd
Added by planetmaker over 10 years ago

Fix: Alignment of construction phase of temperate office building (part of issue #77)

Revision 240:9355a51e9c27
Added by planetmaker almost 10 years ago

Fix: Align a few town buildings (part of issue #77)

Revision 240:9355a51e9c27
Added by planetmaker almost 10 years ago

Fix: Align a few town buildings (part of issue #77)

Revision 336:0bd11eaefb5e
Added by Ammler over 9 years ago

Fix [#77]: realign old offices 1461-1463

Revision 336:0bd11eaefb5e
Added by Ammler over 9 years ago

Fix [#77]: realign old offices 1461-1463

Revision 337:cbd250cdd907
Added by Ammler over 9 years ago

Fix [#77]: realign other houses (1464,1470)

Revision 337:cbd250cdd907
Added by Ammler over 9 years ago

Fix [#77]: realign other houses (1464,1470)

Revision 339:9559ac9149ff
Added by Ammler over 9 years ago

Fix [#77]: realign small flats (1519-1523)

Revision 339:9559ac9149ff
Added by Ammler over 9 years ago

Fix [#77]: realign small flats (1519-1523)

History

#1 Updated by foobar over 10 years ago

  • Target version set to 0.1.0-alpha5

#2 Updated by Ammler over 10 years ago

You didn't assigne this bug to you, so we might help you here, but do you have a example?

#3 Updated by foobar over 10 years ago

Ah, completely forgot about this. Made a screenshot and savegame a while ago...

#4 Updated by Ammler over 10 years ago

  • Target version changed from 0.1.0-alpha5 to 0.2.0

---> alpha5 released, so this has to be done later ;-)

#5 Updated by foobar over 10 years ago

  • Target version changed from 0.2.0 to 0.1.0-alpha6

#6 Updated by planetmaker over 10 years ago

  • Status changed from New to Confirmed
  • Estimated time changed from 2.00 to 3.00

Besides a mis-alignment, also some of the sprites seem to be one pixel too wide:

  • SmatZ is now known as Guest89
    <Rubidium> planetmaker: why are so many town buildings wider than a tile's wide, i.e. the Limitations part of http://wiki.ttdpatch.net/tiki-index.php?page=DrawingSprites
    <planetmaker> uhm... I guess because they were drawn that way. But are there?
    <planetmaker> the houses which I coded should be < 32 pixels - iirc
    <planetmaker> but, sure, there might be others. Do you have an example?
    <Rubidium> planetmaker: everything with "66 31" is suspect
    <Rubidium> e.g. sprite 384 of building.pcx
    <Rubidium> (also known as #77)
    <Rubidium> or shall we call it OGFX#77?
    <planetmaker> issue numbers a unique throughout the whole devzone, so #77 is fine :
    )
    <planetmaker> hm... but why is everything with 66 -31 suspect? It's 63 pixels across from left to right, isn't it?
    <planetmaker> And #384... well, has a transparent line on the left and right. Though, admittedly, there are two non transparent pixels on the left of that building. Dunno why.
    <planetmaker> *sprite #384 in buildings.pcx
    <Rubidium> planetmaker: because (town) building sprites must be at most 64 pixels wide
    <Rubidium> and with 66 pixels wide, the 31 is likely wrong too
    <planetmaker> well. But that sprite is from x=674 to x=739, thus with a delta of 26+39 = 65 pixels. And one of those lines is completely transparent.
    <Rubidium> thus, as described in the NewGRF specs/TTDP wiki it will glitch
    <planetmaker> indeed with the two left pixels it may.
    <Rubidium> still, if it's 2 wider and still centered, the xoffs needs to be 1 less
    <planetmaker> most likely, yes
    <planetmaker> and those two pixels could be shaved off w/o significant loss.

#7 Updated by foobar over 10 years ago

  • Target version changed from 0.1.0-alpha6 to 0.2.0

#8 Updated by foobar over 10 years ago

Misaligned: construction stage of large office block. In the screenshot it's the construction stage of the building to the right. Coincidentally right next to each other :)

#9 Updated by Ammler almost 10 years ago

  • Target version changed from 0.2.0 to 0.2.1

rest (if there is) can be done later ;-)

#10 Updated by Ammler almost 10 years ago

just found on the current PS

#11 Updated by Ammler almost 10 years ago

#12 Updated by planetmaker almost 10 years ago

  • Target version changed from 0.2.1 to 0.2.2
  • Estimated time deleted (3.00)

the last two buildings seem to be temperate ones. In a plain arctic game I don't find them and it doesn't happen with "usual" grfs which disable houses.

#13 Updated by Ammler over 9 years ago

#14 Updated by Ammler over 9 years ago

from my test game:

#15 Updated by Ammler over 9 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

All house alignment issues fixed?

#16 Updated by Ammler over 9 years ago

  • Status changed from Resolved to Closed

no feedback = everything fine

Also available in: Atom PDF