Bug #7184

wrong sprites in 8bpp mode

Added by Sylf over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:2014-09-23
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

When openttd is running in 8bpp mode, the industry sprites are loaded incorrectly.

yeti-8bpp.png (73.5 KB) Sylf, 2014-09-23 07:31

Associated revisions

Revision 117:6dd9a16ce7ac
Added by Sylf over 5 years ago

Updated 8bpp sprite code, fixing the wrong sprites shown in 8bpp mode. Issue #7184

History

#1 Updated by V453000 over 5 years ago

Since I have no idea how to mass-convert PNGs to 8bpp palette, I will create one huge x1 zoom sprite file almost automatically put together by After Effects, and then I will always just update one file.

#2 Updated by V453000 over 5 years ago

Do we want 8bpp/x1 to animate?

#3 Updated by V453000 over 5 years ago

We dont! :D

#4 Updated by V453000 over 5 years ago

  • % Done changed from 0 to 50

#5 Updated by Sylf over 5 years ago

  • % Done changed from 50 to 80
  • Status changed from New to Confirmed

Code has been implemented and submitted.
We should review the 8bpp sprites - the palette conversion wasn't 100% right. Maybe a different palette without company color part needs to be used when converting 32bpp to 8bpp.

#6 Updated by V453000 over 5 years ago

  • Status changed from Confirmed to Closed

should be fixed with non-animating colours

#7 Updated by V453000 over 5 years ago

  • % Done changed from 80 to 100

Also available in: Atom PDF