Feature #680

Check for engine pool being enabled

Added by planetmaker about 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:2009-12-12
Priority:LowDue date:
Assignee:planetmaker% Done:

100%

Category:General NFO
Target version:2.0

Description

Enabling the engine pool is a good idea and saves trouble with people loading multiple sets. What about just disabling this newgrf, if it's off?

However the answer, though, we should at least take some kind of action.

Engine pool is variable 85, flag 78 ( http://wiki.ttdpatch.net/tiki-index.php?page=TTDPatchFlags )

version_and_settings_check.diff Magnifier (939 Bytes) planetmaker, 2009-12-12 19:12


Related issues

Related to 2cc train set - Bug #142: Cargotranslation table dont seem to work as intended Closed 2009-05-29

Associated revisions

Revision 400:ecd4a984a9b5
Added by planetmaker about 10 years ago

Change: Abort if TTDP or too old OpenTTD versions are found. Change: Issue an error, if the engine pool is disabled (closes #680). Fix: Don't skip the cargo translation table if we have a correct OpenTTD version (closes #142)

History

#1 Updated by planetmaker about 10 years ago

Please test the attached diff whether it does what we want (it only issues a non-fatal error, if the engine pool is off).

Also, I wondered about: as it is now, the cargo translation table is skipped, if we have a current OpenTTD version. That might be the cause that it didn't work with it in recent versions of this set. So, my guess is, this diff also fixes another problem (issue #142).

#2 Updated by planetmaker about 10 years ago

  • File version_and_settings_check.diff added

the missing diff

#3 Updated by planetmaker about 10 years ago

update. Checking the reverse is better

#4 Updated by planetmaker about 10 years ago

  • File deleted (version_and_settings_check.diff)

#5 Updated by planetmaker about 10 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset r400.

Also available in: Atom PDF