Bug #6584

"action 1 and 2 are not valid before action 8"

Added by skyem123 over 5 years ago. Updated almost 4 years ago.

Status:RejectedStart date:2013-11-23
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

When I compile this NML file: (If you want comments please ask. My compiling system is slightly odd)
https://dl.dropboxusercontent.com/u/5321798/newGRF_src/rail/output.nml
It works fine in openTTD but when I uploaded it to BaNaNas it crashed the openttd.org server. (It doesn't happen now)
They told me the problem that occurred in my newGRF was "action 1 and 2 are not valid before action 8". I have no idea what that means.

rail.zip - Should Compile (169 KB) skyem123, 2013-11-24 12:19

rail.zip - Updated Files (169 KB) skyem123, 2013-11-24 12:24

History

#2 Updated by skyem123 over 5 years ago

Forgot to add custom_tags.txt

#3 Updated by planetmaker over 5 years ago

  • Status changed from New to Confirmed

That is actually a limitation in the grf specs and a missing piece of documentation with NML: the grf block must (currently) be defined first thing within a grf, everything else should follow.

The better solution to documenting this behaviour is to have NML automatically detect the grf block and output the resulting code at the start of the grf file.

#4 Updated by frosch almost 4 years ago

  • Status changed from Confirmed to Rejected

This is similar to object/industry/house/rail substitute. They define the entities and have to appear before other things dealing with the entities.

Because of "if" and GRF parameter checks it's not possible for NML to automatically move the GRF block.

The documentation meanwhile reflects that GRF must be at the beginning.

Also available in: Atom PDF