Bug #5630

Sr2 has incorrect depot positioning

Added by Junafani over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2013-05-12
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

Sr2 has incorrect positioning in depot window. It is too left and overlaps wagon (or engine) in front of it. This also means that Sr2 is not connected to wagons it is pulling and there is quite big gap between them.

Sr2_depot_bug.png (1.29 KB) Junafani, 2013-05-12 20:54

sr2.png (10.3 KB) juzza1, 2013-05-12 21:07

History

#1 Updated by Junafani over 6 years ago

This also affects it's positioning in game world. SR2 also has some other problems for it's game world positioning. See bug #5633.

#2 Updated by juzza1 over 6 years ago

  • Status changed from New to Feedback

Try a new game and see if it still happens. We've had these problems before because I haven't updated the minimum compatible version after breaking backwards compatibility. The newest nightly has minumum compatibility set at the newest revision, R126.

#3 Updated by juzza1 over 6 years ago

  • File deleted (sr2.png)

#4 Updated by Junafani over 6 years ago

Tested creating a new game and bug is still appearing. Image was originally taken in Windows OpenTTD 1.3.0 beta 1, but it also happens in win stable 1.3.0 and also in newest win nightly r25237. In all these testings I created a new game. Original bug submission image has few additional NewGRFs, but this also happens without NewGRFs.

Finnish Trainset is version r126 and downloaded from http://bundles.openttdcoop.org/finnishtrainset/nightlies/r126/ I assume it is correct place for downloading it?

#5 Updated by juzza1 over 6 years ago

Yes, that is the correct place to download the nightly. I cannot replicate your issue. Looking at the code and sprites, there is nothing that should create this kind of behaviour. Try (temporarily) deleting your whole users\YOURUSERNAME\Documents\OpenTTD folder, then start the game, and try a new game with only the finnishtrainset.grf in your newly created OpenTTD\newgrf folder, and see if the bug still happens.

#6 Updated by juzza1 over 6 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

I'm closing this one, since it is the same as the other bug you are having. Post your savegame if it still isn't fixed, maybe we can work something out.

Also available in: Atom PDF