Bug #4150

towns/temperate/1501-1506

Added by Alberth almost 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:2012-08-07
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

//house
base_graphics spr1501(1501, "sprites/png/houses/buildings.png")                { [ 274, 3192,  64,  35, -31,  -4] }
base_graphics spr1502(1502, "sprites/png/houses/buildings.png")                { [ 514, 3192,  38,  24, -16,  -1] }
base_graphics spr1503(1503, "sprites/png/houses/buildings.png")                { [ 354, 3192,  64,  35, -31,  -4] }
base_graphics spr1504(1504, "sprites/png/houses/buildings.png")                { [ 562, 3192,  38,  24, -16,  -1] }
base_graphics spr1505(1505, "sprites/png/houses/buildings.png")                { [ 434, 3192,  64,  35, -31,  -4] }
base_graphics spr1506(1506, "sprites/png/houses/buildings.png")                { [ 610, 3192,  38,  24, -16,  -1] }

Another unclarity: The sprites in 1501-1506 shows several houses, the opengfx source says 'house'. Who is right?

1513-1518 seems to have a simular unclarity.

Associated revisions

Revision 139:e611f8b99ad9
Added by zephyris almost 8 years ago

Fix: Correct render of ground sprite for first construction stage of temperate house 1501-0506. (Bug #4150)

History

#1 Updated by zephyris almost 8 years ago

The original windows graphics are a collection of three houses, OpenGFX has a single house... OpenTTD calls them "Town Houses".

#2 Updated by zephyris almost 8 years ago

1513-1518 is a pair of houses in the original windows graphics, OpenGFX has a single house. OpenTTD calls them "Houses".

#3 Updated by zephyris almost 8 years ago

  • Status changed from New to Closed

Double checked these sprites in-game; I'm going to call it closed, the OpenGFX sprites are at fault.

#4 Updated by Alberth almost 8 years ago

  • Status changed from Closed to Reopened

Fair enough :)

I coded the sprites (that is, my computer is working on the first try), but towns/temperate/1501-0506/*_0001.png looks weird; the tile is only partly visible. Could you check/re-generate that sprite please?

(and the directory name is wrong, but I can live with that :) )

#5 Updated by zephyris almost 8 years ago

  • Status changed from Reopened to Closed
  • % Done changed from 0 to 100

Applied in changeset e611f8b99ad9.

Also available in: Atom PDF