Support #4081

IRM/VIRM IV depot sprite

Added by Transportman over 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2012-07-19
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:2.0.0-beta1

Description

The depot sprite for the IRM/VIRM IV uses the Olympic livery in Alpha 6, while the IRM-III and VIRM-VI use the default NS livery as depot sprite.

Associated revisions

Revision 657:448160f94958
Added by foobar almost 7 years ago

Change: no longer display special liveries in purchase menu (closes #4081)

History

#1 Updated by Transportman over 7 years ago

The reason it happens is because the default fallback for the switchblock that defines the depot sprite is actually the Olympic livery:

switch(FEAT_TRAINS, SELF, switch_emu_IRMIV_purchase, current_year) {
0..2001: spriteset_emu_IRMIV_irm_purchase;
2002..2004: spriteset_emu_IRMIV_virm_purchase;
2010..2011: spriteset_emu_IRMIV_ovchip_purchase;
spriteset_emu_IRMIV_olympic_purchase;
}

The other versions (the III and VI) don't have such a switchblock, but just use the NS livery.

#2 Updated by foobar over 7 years ago

  • Tracker changed from Bug to Support
  • Status changed from New to Feedback

This is by design. The idea is that the most recent livery is shown. This should be the common behaviour for most trains.

#3 Updated by Transportman over 7 years ago

Ok. I think it should show the default livery (for that year) as depot sprite instead of the most recent livery, since the most recent livery can be some promotional livery that was only used on a small number of trains.

And I'm not sure if there is a train that actually has this, but what if the most recent livery was removed for some reason? Would it then show the most recent (removed) livery as depot sprite, or the default livery?

#4 Updated by foobar about 7 years ago

With this I wanted to show players that there is a new livery available, so that if you want it you can get it. However, we can decide to not do that for special liveries, only for regular liveries. Then this would need changing at other trains as well. ICM comes to mind here, possibly DH2 too.

What currently happens: let's say there is a livery A, then for a short period of time a special livery B is introduced on some trains, and eventually all trains are again repainted in livery A. In this case livery B is only shown in the purchase menu during the time that livery B was used. After that also the purchase menu will revert to A.

#5 Updated by Transportman about 7 years ago

I posted a message on the forum to get some more feedback on this: http://www.tt-forums.net/viewtopic.php?f=26&t=5033&p=1044525#p1044525

#6 Updated by foobar almost 7 years ago

  • Target version set to 2.0.0-beta1

#7 Updated by foobar almost 7 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Applied in changeset 448160f94958.

Also available in: Atom PDF