Code Review #3852

sprite offsets

Added by Eddi over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:2012-03-20
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

did anyone even try the grf lately? i'm getting wrong offsets and cuts all over the place. and i'm unable to find what caused it or when it started to appear...

Associated revisions

Revision 675:ebfcb29e94a2
Added by oberhuemer over 7 years ago

Fix: Correct sprite dimensions and some offsets (closes #3852).

History

#1 Updated by oberhuemer over 7 years ago

It's only the depot GUI, and only for everything with length > 6; the graphics of the first slice are shown instead of the whole thing.
The running cost is also shown as 0 in the depot, might need to revert that useless modification.

#2 Updated by Eddi over 7 years ago

yes, i already fixed the purchase list sprites.

but in the depot, the offsets are wrong. i have the suspicion that the depot 32px flag is not handled properly, but i can't see why.

also, while moving around on the tracks, there occasionally seem to be some pixels cut off from sprites.

#3 Updated by Eddi over 7 years ago

soo... the depot thingies turned out to be a compiler optimisation issue in openttd. leaves the cut off vehicle slicing needing review.

#4 Updated by oberhuemer over 7 years ago

After investigation:
- The entire rear is cut off when going straight up, leaving only roofs visible.
- When going diagonally upwards, two columns are cut off at the rear corner.
- When going diagonally downwards, one column is cut off at the rear corner.
- When going horizontally to the right, one column is cut off the left side.

#5 Updated by oberhuemer over 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset ebfcb29e94a2.

Also available in: Atom PDF