Bug #3161

internal error with random_switch type 84 (FORWARD_SELF/BACKWARD_SELF)

Added by Eddi over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2011-10-15
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

CETS r255 with this patch applied: http://www.informatik.uni-halle.de/~krause/random_switch.diff
throws this error:

nmlc: An internal error has occurred:
nmlc-version: r1689 (9994556afb1d)
Error: (NameError) "global name 'rtype_info' is not defined".
Command: ['/home/johannes/bin/nmlc', '-M', '--MF', 'cets.gfx.dep', 'cets.nml']
Location: File "/home/johannes/.openttd/dbs/nml/nml/actions/action2random.py", line 116, >in parse_randomswitch_type

Associated revisions

Revision 1701:00b69997f96d
Added by yexo over 8 years ago

Fix #3161: random_switch was broken due to a typo (Eddi)

Revision 1701:00b69997f96d
Added by yexo over 8 years ago

Fix #3161: random_switch was broken due to a typo (Eddi)

History

#1 Updated by Eddi over 8 years ago

i checked in the above patch in CETS r256 and a workaround in r257, so use r256 if you want to reproduce the issue

#3 Updated by yexo over 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset 00b69997f96d.

Also available in: Atom PDF