Bug #280

standard signals

Added by Ammler almost 11 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2009-06-27
Priority:HighDue date:
Assignee:-% Done:

100%

Category:Base
Target version:0.3.0

Description

the signals are very hard to see:

signals.png (117 KB) Ammler, 2009-06-27 13:52

comparison.png (12.9 KB) foobar, 2009-08-13 20:16

lightersig.png - Slightly ligher backsides of PBS signals (9.83 KB) bilbo, 2010-03-29 02:14

12751290.png (14.4 KB) 2006TTD, 2010-08-14 06:32

presignals.png (38 KB) 2006TTD, 2010-08-16 14:22

Quarwich_Transport__22-04-1950.png (18.6 KB) 2006TTD, 2010-08-16 17:20

signals-normal.png (8.09 KB) 2006TTD, 2010-08-18 09:32

signals-entry.png (9.16 KB) 2006TTD, 2010-08-18 09:32

signals-exit.png (9.05 KB) 2006TTD, 2010-08-18 09:32

signals-combo.png (9.12 KB) 2006TTD, 2010-08-18 09:32

Bildschirmfoto_2010-08-21_um_11.13.40.png (1.57 MB) planetmaker, 2010-08-21 11:22

signals-combo2.png - With Palette (10.3 KB) 2006TTD, 2010-08-21 17:41

signals-entry2.png - With Palette (10.2 KB) 2006TTD, 2010-08-21 17:41

signals-exit2.png - With Palette (10.2 KB) 2006TTD, 2010-08-21 17:41

signals-normal2.png - With Palette (9.11 KB) 2006TTD, 2010-08-21 17:41


Related issues

Related to OpenGFX - Feature #840: Improved signal sprites Closed 2010-03-17

Associated revisions

Revision 483:bd557a1795a7
Added by Ammler almost 10 years ago

Feature #840, #280: template for signals

Revision 483:bd557a1795a7
Added by Ammler almost 10 years ago

Feature #840, #280: template for signals

Revision 489:8bb93c641446
Added by Ammler almost 10 years ago

Fix #280: new light signals by 2006TTD

Revision 489:8bb93c641446
Added by Ammler almost 10 years ago

Fix #280: new light signals by 2006TTD

Revision 502:d359a364ffb1
Added by Ammler almost 10 years ago

Fix #280 (r483): a bit of readjustment, still trying to reach a general offset

Revision 502:d359a364ffb1
Added by Ammler almost 10 years ago

Fix #280 (r483): a bit of readjustment, still trying to reach a general offset

Revision 509:13ecdfffef64
Added by planetmaker almost 10 years ago

Fix #280: Remove animation pixels from red signals

Revision 509:13ecdfffef64
Added by planetmaker almost 10 years ago

Fix #280: Remove animation pixels from red signals

History

#1 Updated by foobar almost 11 years ago

  • Target version set to 0.1.0-alpha6

#2 Updated by Ammler almost 11 years ago

  • Target version deleted (0.1.0-alpha6)

I think, we need feedback here, If I am the only one, we can reject it.

#3 Updated by athanasios almost 11 years ago

No, you are not alone! Are there signals there? :-)

#4 Updated by Ammler almost 11 years ago

  • Status changed from New to Confirmed

ok, then we set it to "confirmed" ;-)

#5 Updated by foobar almost 11 years ago

Is it me or is there no difference where it says that it's a good fix?

#6 Updated by planetmaker almost 11 years ago

foobar wrote:

Is it me or is there no difference where it says that it's a good fix?

It was my impression that the sign in the screenshot has nothing to do with the (barely visible) signals. It's just a relict from the game the screeny was taken from.

#7 Updated by Ammler almost 11 years ago

Yeah, sorry about the sign, nothing to do with the bug report. ;-)

#8 Updated by foobar almost 11 years ago

Ah, that explains :)

Also I think the dip between the two bridges is ugly :P

#9 Updated by foobar almost 11 years ago

Comparison of signals: Back side of OGFX signal is darker than TTD. Making signal state brighter should improve the visibility quite a bit I think.

#10 Updated by Ammler almost 11 years ago

  • Assignee set to bilbo

bilbo, what do you think?

#11 Updated by bilbo almost 11 years ago

Perhaps the signals are a bit too dark. I'll try to create a lighter version and then I'll post comparisons here.

#12 Updated by Ammler over 10 years ago

  • Category set to Base
  • Assignee deleted (bilbo)
  • Target version set to 0.3.0

#13 Updated by Ammler about 10 years ago

  • Priority changed from Low to Normal

#14 Updated by bilbo about 10 years ago

I tried creating slightly lighter backsides of PBS signals, attaching screenshot from game. Do you think it looks better and should be committed? Should I try to improve the ordinary signals too? (I have not touched those ... yet)

#15 Updated by Ammler about 10 years ago

Nice to see you back :-)

The issue is specially with the usual signals and catenary. (As on the screen)

I can't tell you how it should be done, I just know, the original ttd signals are better distinguishable.

#16 Updated by planetmaker about 10 years ago

Looking at the original signals, the light is always at least two pixels while the current OpenGFX signals often only have a light of the size of one pixel. At this scale that's a very noticable difference and makes them far worse distinguishable. Increasing the ease to distinguish signal states while maintaining a nice look is IMHO the biggest challange for all the light signals, especially the block signals (path signals have double red lights and are much less of a concern).

#17 Updated by 2006TTD almost 10 years ago

Further adjustments done. Please use the columns pointed by the green arrows.
Changes:
A. Lights became brighter and larger
B. Cone shaped lights preserved
C. More obvious, but still subtle hints for the lights facing back of us i.e. 1289, 1290

#18 Updated by 2006TTD almost 10 years ago

And where can I find the presignals and PBS?

#19 Updated by planetmaker almost 10 years ago

Many signals (pre-signals and alike) are found in infra08.pcx.
The PBS signals are in signals_pbs.pcx.

http://dev.openttdcoop.org/projects/opengfx/repository/show/sprites/pcx

Don't worry about replacing them within infra08.pcx; new versions of block signals I'd rather like to see in a separate file just like the pbs signals are already now; possibly such that a full set of signals is in one graphics file, so that another full set for another climate could use the same offsets. As usual: equal spacing helps, but no template for normal signals exists so far.

#20 Updated by 2006TTD almost 10 years ago

Wow there's almost 100 of them. But let me see how the modified signal sprites look like first.
Moreover, that may be too many for me. Maybe later.

#21 Updated by planetmaker almost 10 years ago

Well. There are: (normal+pre+combo+exit)*(6 facings)*(red+green) = 48 per set
PBS signals are fine and don't need re-doing IMHO.

#22 Updated by 2006TTD almost 10 years ago

planetmaker wrote:

PBS signals are fine and don't need re-doing IMHO.

OK, I will do presignals only.
And I will choose to remake the signals with a darker backside pole i.e. 1238 to 1285.

#23 Updated by planetmaker almost 10 years ago

There must be one facing of the signals missing though I'm not entirely sure which; I only count 7 facings while there must be 8: + and x directions.

Besides that: a nice improvement; I like that the principle style is kept :-)

#24 Updated by 2006TTD almost 10 years ago

But I just copied all 1275-1290 from the sprite list, and there is 16 = 8 pairs, so as in the file 1275190.png
It should be complete.
And moreover, is the sprite list up to date?
I use this link:
http://mz.openttdcoop.org/opengfx/authors/script.php?feature=spritesbyfile&q=ogfx1_base&orderby=range_start&direction=ASC
Is it right?
Also, is it ok for me to only remake the signals with darker pole?

#25 Updated by 2006TTD almost 10 years ago

Presignals are done. So this should mark the end of this issue.

#26 Updated by Ammler almost 10 years ago

We need some logic on the sprite ordering to make coding somehow templateable, there is also the UK semaphores of Arcon (#840).

Measure every single sprite could be tedious.

#27 Updated by 2006TTD almost 10 years ago

Do I need to follow up then? Or is my work here done?

#28 Updated by Ammler almost 10 years ago

Well, ideas are welcome :-)

Maybe it would need rearrangement.

Also the standard signals are still missing.

#29 Updated by 2006TTD almost 10 years ago

But haven't I done the standard signals in 12751290.png ?

#30 Updated by 2006TTD almost 10 years ago

Suggestion for order: '/' then '\' then '-' then '|'
In each direction: Facing us then Facing back of us
In each facing: Red then Green

So the order is: /-Facing us-Red, /-Facing us-Green, /-Facing back of us-Red, /-Facing back of us-Green, \-Facing us-Red
etc.

#31 Updated by Ammler almost 10 years ago

the order is fixed and given by TTD

I have added a template file and also committed already the generic semaphores from Born Acorn to give a example. Maybe you like to make your signals self, either as png or pcx.

#32 Updated by 2006TTD almost 10 years ago

Transfer to template done.

#33 Updated by Ammler almost 10 years ago

  • Status changed from Confirmed to Closed
  • % Done changed from 0 to 100

Applied in changeset 8bb93c641446.

#34 Updated by 2006TTD almost 10 years ago

  • Status changed from Closed to Reopened
  • Priority changed from Normal to High
  • % Done changed from 100 to 80

In the game I found out that some of the red pixels become red cycle pixels. I checked in paint but the pixels are R:252, not red cycle R:255.
Why did that happen?
A fix is needed.
Using OpenTTD r20584 and OpenGFX r497

#35 Updated by planetmaker almost 10 years ago

I can confirm the flashing pixels. Also alignment could be adjusted:

#36 Updated by Ammler almost 10 years ago

you should save the pngs with indexed palette, then we can be sure, nothing changes with converting to the palette

#37 Updated by Ammler almost 10 years ago

I expected "right" colors and didn't use "reduced" palette for converting to indexed colors.

Also checkout the tool TTDViewer, it might help to find action colors nicely :-)

#38 Updated by 2006TTD almost 10 years ago

Here are the same images with palette.
I will also check out TTDViewer.

#39 Updated by Ammler almost 10 years ago

  • Status changed from Reopened to Closed
  • % Done changed from 80 to 100

Applied in changeset d359a364ffb1.

#40 Updated by Ammler almost 10 years ago

  • Status changed from Closed to Reopened

the issue is still progress...

#41 Updated by planetmaker almost 10 years ago

  • Status changed from Reopened to Closed

Applied in changeset 13ecdfffef64.

Also available in: Atom PDF