NML now using python 3.2+

NML nightlies leading towards NML 0.4.0 require now python 3.2 or newer
Added by planetmaker about 3 years ago

Today Alberth and myself changed the required python version of NML nightly versions and a future NML 0.4.0 to python 3.2 or newer as python2 is slowly phasing out, and also the imaging module is better supported with python3. For some time there will continue be updates to the 0.3 branch as well with an occasional maintenance release, though.

If you're on windows, this is of little consequence to you, we continue to provide an exe file which can be used out-of-box, now based on python 3.3.

If you're on OSX or linux and use nmlc from a repository checkout, you'll want to use the package manager of choice and install python3 and python3-ply and python3-pillow (or called python3-imaging or similar).

If you encounter any problems, please let us know :)

Also package maintainers may consider to already look into updating their dependency lists accordingly

Enjoy,
Alberth & planetmaker


Comments