Feature #6871

python2 -> python3 conversion

Added by planetmaker almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:2014-04-19
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:0.4.0

Description

Attached the version of http://devs.openttd.org/~alberth/py3_changes_20140319.patch tested:

planetmaker@localhost:~/ottd/grfdev/nml$ python3 setup.py bdist_egg
(...)
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/base_sprites.py to base_sprites.cpython-33.pyc
Sorry: TabError: inconsistent use of tabs and spaces in indentation (base_sprites.py, line 36)

byte-compiling build/bdist.linux-x86_64/egg/nml/ast/assignment.py to assignment.cpython-33.pyc
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/conditional.py to conditional.cpython-33.pyc
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/produce.py to produce.cpython-33.pyc
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/disable_item.py to disable_item.cpython-33.pyc
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/base_statement.py to base_statement.cpython-33.pyc
byte-compiling build/bdist.linux-x86_64/egg/nml/ast/spritecount.py to spritecount.cpython-33.pyc
File "build/bdist.linux-x86_64/egg/nml/ast/spritecount.py", line 8
print indentation*' ' + 'Sprite count'
^
SyntaxError: invalid syntax
(...)

py3_changes_20140319.patch Magnifier (36.1 KB) planetmaker, 2014-04-19 07:24

History

#1 Updated by planetmaker over 3 years ago

  • Assignee deleted (Alberth)
  • Status changed from New to Closed

Duplicate of #2722

Also available in: Atom PDF