Patch #4385

Feature: Have 'untranslatable' strings

Added by Alberth over 5 years ago. Updated almost 5 years ago.

Status:RejectedStart date:2012-10-09
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Some strings in language files are not intended for translation, eg

STR_ANSWER                     :42
However, there is currently no way to indicate that.
The patch adds '=' in language files as an alternative to ':'. It only has special meaning in the default language file, namely it gives a warning when such strings are translated. However, the translation is still accepted. I don't see a special reason to make the translation impossible; the warning is probably sufficient to make authors drop the translation.

(connected to this, the string reports at the devzone should be upgraded to understand '=')

untranslatable_strings.patch Magnifier (4.79 KB) Alberth, 2012-10-09 19:25

History

#1 Updated by yexo over 5 years ago

I've discussed this with planetmaker and while we see a slight one-time advantage for translators we're not sure about it. The benefits are small: those untranslatable strings only need to be copied once to all translations. For the final grf size it doesn't matter, since as long as a translation is an exact duplicate of the base string nml won't put it in the grf.

A second issue is the chosen syntax. Personally I'd rather see a prefix for the like like @ or -.

All in all I do think translations can use some work, but I feel time is better spend on finally creating a webtranslator for nml projects.

#2 Updated by Alberth over 5 years ago

(Re-adding the post, as it seems to be lost)

Issue #4385 has been updated by yexo.

I've discussed this with planetmaker and while we see a slight one-time advantage
for translators we're not sure about it. The benefits are small: those
untranslatable strings only need to be copied once to all translations. For the
final grf size it doesn't matter, since as long as a translation is an exact
duplicate of the base string nml won't put it in the grf.

A second issue is the chosen syntax. Personally I'd rather see a prefix for the like
like @ or -.

All in all I do think translations can use some work, but I feel time is better
spend on finally creating a webtranslator for nml projects.

#3 Updated by Alberth over 5 years ago

I agree that making a web translator makes translation available for a much larger group of people and authors, and is a worthwhile effort.

However, relying on keeping track of the state of translations by means of some unknown data internal to some web app for a project does not sound like a good idea to me.
In particular since you cannot express that state in a human-readable and editable form as part of the project data.

NML may have started as a newgrf compiler, but for many it is much more nowadays. Taking proper care of translations is one aspect of that.

#4 Updated by yexo over 5 years ago

Well, if we're going for that we need to store all state (not just "untranslatable", but also last translated revision and whether or not it's reviewed since then) in the text file. I'm not against this approach (it might even make a translator tool easier, since it doesn't have to store state except maybe for some cache). It does however require a bit more planning up front and not just adding new syntax for untranslatable strings without any further plan.

#5 Updated by Alberth almost 5 years ago

  • Subject changed from Feature: Have 'untranslatable' strings to Feature: Have 'untranslatable' strings
  • Status changed from New to Rejected

A nice idea, but not complete enough

Also available in: Atom PDF