Support #3801

Sprite templating instructions

Added by foobar over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:2012-03-11
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Graphics
Target version:2.0.0-beta1

Description

Below are instructions how to template sprites for this set.

Template:
  • The empty template to use is attached below.
  • Each row of 8 boxes is for one vehicle/livery.
Aligning the sprites:
  • Get the sprites from the big file: http://dev.openttdcoop.org/projects/dutchtrains/repository/raw/gfx/dutchtrainsw.png
  • The sprites must be ordered in travelling direction: up, top right, right, bottom right, down, bottom left, left, top left.
    • They already appear in the correct order in the big file, so that's easy enough.
  • The first four sprites must be aligned in the bottom right of the blue boxes, the last four sprites in the bottom left of the boxes.
    • There's an alignment template provided for short sprites, so you can see how they should be put it.
  • Note that some MU sprites in _ views are 1px bigger than the templates provided. Everything that sticks out of the template will not be in the game:
    • Make sure that the front of the MU is completely in the blue box.
    • Let subsequent middle parts stick out of the blue box at the same side as the corresponding front part.
    • Except the last part, of which the end should be completely in the blue box.
    • No need to remove bits that stick out, as long as they don't protrude into other blue boxes. This way we can see that these sprites are indeed too long and fix them some point later.
  • Important: do not move the blue boxes around. They are where they are for a reason ;)
One vehicle per file:
  • Put all sprites belonging to one vehicle in a single file.
  • Extend the file as necessary. The y-coordinate of the top left corner of each row of blue boxes must be a multiple of 30.
    • Tip: Copy a block of multiple rows and put the first copied row on top of the last existing row, then the distance between the boxes will be correct without having to count it.
Fill in the name and copyright:
  • Put the name of the vehicle/wagon above the "License: GPLv2+".
  • Put the nickname of the vehicle designer behind the (c). If more people worked on one vehicle, you can use more lines here.
  • The font used is of no importance, as long as it's readable.
Saving:
  • Remove excess blue boxes (move the copyright up).
  • Remove the excess white at the right. This is there as temporary holding for sprites from the big sprite sheet.
  • Make sure the top left of the first row of sprites is exactly in the top left of the file.
  • Choose a recognizable filename. Doesn't matter what, I'll probably be renaming it anyways.
  • All files must be saved with the Windows palette. The template already has this palette applied, so as long as you (or your editor) don't remove that you'll be fine.

Do not use this issue for posting sprites you've templated. Make a new issue instead.
You may use this topic to indicate that you're working on something

Purchase menu sprites:
  • There's no need to include a purchase menu sprite in the templates. These must be supplied in separate files according to #3795.
  • Please do also make the purchase menu sprites when templating a vehicle.

List of sprites to be templated:

  • Steamers from attached png below

alignment_example.png (4.97 KB) foobar, 2012-03-11 17:02

Template error.png - The error in the template (21.4 KB) Transportman, 2012-04-07 12:13

empty_template.png - r428 (4.85 KB) foobar, 2012-04-07 12:47

steamers.png (20.7 KB) foobar, 2012-04-07 12:47


Related issues

Related to Dutch Trains 2 - Feature #3850: Ketelwagen & ZHESM BC6 -> template & purchase Closed 2012-03-19

History

#1 Updated by foobar over 2 years ago

  • Description updated (diff)
Sprites currently taken:
  • Future HST (Transportman)
  • ICM (Mahoo76)

Please use this issue to indicate what you're working on. Just post the results in a NEW issue, one per train/wagon. That is easier for me to keep track of. Thanks!

#2 Updated by Mahoo76 over 2 years ago

Mat '34 (Mahoo76)

#3 Updated by Transportman over 2 years ago

TGV (Transportman)

#4 Updated by Transportman over 2 years ago

TGV is done.

DM '90 is a nice small one to do, so I take that one now.

To make searching for sprites in the big spritesheet easier, take a look at the list of available trains on the wiki, the spritesheet has the same ordering of trains in their respective groups: MU's, post and passenger coaches, Diesel+Electric, steamers, cargo wagons.

#5 Updated by Transportman over 2 years ago

Scratch my comment about the DM '90. It needs the same graphical adjustments as the SM '90, because it also doesn't fit the template. So I think it is wiser to let that one to someone with a more artistic feeling. Instead I will take this one:

DH-1 Wadloper (Transportman)

#6 Updated by Transportman over 2 years ago

DH1 and DH2 done. They were mixed in the big spritesheet so I templated them both at the same time.

#7 Updated by Mahoo76 over 2 years ago

It seems Transportman and I are doing this. I'll have a crack at the cargo wagons. I'll start from the bottom (compost car) and work my way up.

#8 Updated by Transportman over 2 years ago

I'll take the DE1 and DE2. Both are Plan X "Blauwe Engel", so I don't know how far I can split them with the sprites in the spritesheet (so update will follow in the issue I will open for it when I have some progress).

#9 Updated by Transportman over 2 years ago

I am currently working on the DE3 (Plan U).

#10 Updated by Mahoo76 over 2 years ago

Mat '54 & Mat '56, here I come!

#11 Updated by foobar over 2 years ago

  • Description updated (diff)

Updated the list to be templated.

Thanks both of you for your help, much appreciated!

#12 Updated by Transportman over 2 years ago

Do you have the sprite numbers for the DE5? Because I can't find the DE5 ingame in v1, so I have no image available to compare it with (or even a hint which trains are close to it in the big file).

#13 Updated by foobar over 2 years ago

DE5 is 651 to 798

#14 Updated by foobar over 2 years ago

  • Description updated (diff)

Added some more things to the list that we have sitting around.

#15 Updated by Mahoo76 over 2 years ago

Ketelwagen & ZHESM BC6 done

#16 Updated by Transportman over 2 years ago

I'll take the DE5.

#17 Updated by foobar over 2 years ago

  • Description updated (diff)

Updated the list. No new entries.

I'll have a look at the DM/SM '90 myself.

#18 Updated by foobar over 2 years ago

  • Description updated (diff)

DM/SM '90 are done.

#19 Updated by foobar over 2 years ago

  • Target version changed from 2.0.0-alpha1 to 2.0.0-beta1

The remaining untemplated vehicles will not be in 2.0.0-alpha1.

#20 Updated by Mahoo76 over 2 years ago

NSset_open_goederenwagon is done

#21 Updated by Transportman over 2 years ago

NSset_open_goederenwagon3 is also done

#22 Updated by Transportman over 2 years ago

Before I start on the NSset_open_goederenwagon2:

Shouldn't the fire cycle be applied for the cargo (as per issue #3347 http://dev.openttdcoop.org/issues/3347)? If that is true, why all the trouble of templating them all when it is easier to just do that? That would reduce the amount of sprites to put in the template to 4 for each livery, which is way less than 3 for every cargo for each livery. And with a replace colour on the original sprites, it shouldn't be too hard to get the fire cycle colour on the original cargo in the sprites.

#23 Updated by foobar over 2 years ago

I'm fine either way. Currently some are coded with the fire cycle, some are coded with fixed cargoes. The goal is indeed to have everything with the fire cycle, but as I'm not doing that, I'm fine either way :P

So if you want to do that now, go right ahead. You can probably copy the cargo texture of one of the gen1_* wagons that Voyager drew.

#24 Updated by Transportman over 2 years ago

It's done. Just one bad message that I didn't notice until now, because then it was all templating separate sprites, but now I could actually copy paste a lot because there are only 4 sprites for each stage. The bad message is:

The template contains an error. 1/3 of the blue boxes in the 7th column miss a row of pixels. Therefore the sprites get one pixel to high compared to the other sprites. I don't know if you are aware of it. I didn't fix it in this run. The problem is in the second+3*nth row.

#25 Updated by Transportman over 2 years ago

I have attached an image that shows the error. In the other rows the black lines align to the bottom of the blue boxes.

#26 Updated by foobar over 2 years ago

Crap. I've seen that issue a couple of times in the previously templated sprites, and fixed it there. Appearantly it hasn't occured often enough to make me think of an issue with the template.
Anyways, a new empty template is attached.

In other news, I also attached the steamers from v1 that also need some templating :)

#27 Updated by foobar over 2 years ago

  • File deleted (empty_template.png)

#28 Updated by Transportman over 2 years ago

I'll take all steamers. Since they are more or less ordered in the original file, I can just do them all in one go and then copy them to separate files (just like the old Goederenwagon sprites)

#29 Updated by foobar over 2 years ago

  • Status changed from New to Closed

All sprites from v1 are templated now. Both of you, thanks for the help!

Also available in: Atom PDF