Bug #3018

Handling of unsupported image formats

Added by Hirundo over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:2011-08-30
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:0.2.0

Description

Copy paste from forum:

-------------
I wanted to check for possible errors, so I downloaded the FIRS source code and tried to compile it myself. I downloaded NML, as written here. I uses MSYS for compiling FIRS, so I put the NML files into the bin directory of MSYS. Without applying any changes to the code, I typed in 'make' and the compilation failed.
Here is the output:
Code:

$ make
[DEP] firs.src.dep
[DEP] firs.gfx.dep
[DEP] Makefile.dep
[LANG] custom_tags.txt
[CPP] firs.nml
[NML] firs.grf
nmlc: An internal error has occurred:
nmlc-version: r1641 (12e868cbe382)
Error: (IOError) "cannot identify image file".
Command: ['C:\\Compiler\\MinGW\\msys\\1.0\\bin\\nmlc.exe', '--grf', 'firs.grf', 'firs.nml']
Location: File "C:\Python27\lib\site-packages\PIL\Image.py", line 1980, in open

make: *** [firs.grf] Error 1

I tried putting NML to a separate directory and adding it to the PATH environment variable, but I got the same result.
I do not have Python installed separately, could it be the cause? At least Python is not mentioned in the Windows part of the NML installation tutorial...
-------------

Since he uses nmlc.exe, I suspect the error is due to nmlc.exe not supporting PCX

In any case, internal errors like these should not happen.

History

#1 Updated by yexo over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Fixed in r1646 before I saw this issue, hence no reference to it.

Also available in: Atom PDF